Laravel Homestead 4.0 and Box 1.0.1

GO PHP 7.1!

Today we’re releasing Homestead 4.0 and an updated box version 1.0.1 for VMware and Virtualbox. Homestead 4.0 requires box version 1.0.0 or higher since we are making the jump from PHP 7.0 to PHP 7.1.

How to Upgrade

If you have Homestead installed globally:

cd /path/to/homestead
git fetch origin
git checkout v4.0.0
vagrant destroy
rm -rf .vagrant
vagrant up

If you have Homestead installed per project:

Open your projects “composer.json” file and ensure the “laravel/homestead:” line is:

"laravel/homestead": "^4.0"

Then run:

composer update
vagrant destroy
rm -rf .vagrant
vagrant up

You may need to run the Homestead make command again to update your Homestead.yaml:

mv Homestead.yaml Homestead.yaml.backup
php vendor/bin/homestead make

Make sure you copy any changes you may need from Homestead.yaml.backup to Homestead.yaml.

Not ready to go to PHP 7.1 yet? No worries!

If you have Homestead installed globally:

cd /path/to/homestead
git fetch origin
git checkout v3.1.0

You should see the output:

HEAD is now at 7924ab4... version

You are now locked at version 3.1. When you’re ready, just checkout master and git pull to get the latest version

If you have Homestead installed per project:

Open your projects “composer.json” file and adjust the “laravel/homestead:” line to:

"laravel/homestead": "3.1.0"

You may need to run the Homestead make command again to update your Homestead.yaml:

mv Homestead.yaml Homestead.yaml.backup
php vendor/bin/homestead make

Make sure you copy any changes you may need from Homestead.yaml.backup to Homestead.yaml.

Need Help? We have opened the issues once again on the Homestead Repository. Please open a new issue and fill out the issue template.

Post Navigation